OpenAPI 3.0 API - Reference to parameter in component block not working

Hi!

I have this

components:
  parameters:
    id:
      in: path
      name: id
      schema:
        type: string
        format: uuid
        example: eb889d08-843f-4951-a695-1a6e63e53e0b
      description: Id of the object     
      required: true

that is referenced this way:

parameters:
      - $ref: '#/components/parameters/id'

When I run the validate against the documentation generated from it I get this error:

And the docs don’t render any of the documentation

Not sure if I am doing something wrong or if postman has a bug but the swagger editor renders it properly.

It works well for schemas

Hi @nicolas,

Your screenshot refers to have the value deleted, the red color signifies it. May I know if you tried validating the API there?

I tried to replicate the same and was able to view them alright:

image image

Could you retry adding and check if the issue persists?

@subramanya.raj Thanks for taking the time to look at this!

Yeah I have been using the validating Button.

You example uses query parameter, could you try with a path one?

Here is a more complete screenshot of the error in the validation view

@nicolas Not sure if this is it but I tried adding “path variables” and that worked for me, screenshots below:

Here is the documentation on the same. Try to create a new API and see if that helps? If the issue persists, please submit a ticket here along with this schema if possible and we will check on this further :slight_smile: