Mass Rename Meraki iPads

We are unable to mass rename iPads. What is the correct string in the [PUT] to pull ‘Serial’ and ‘Name’ from my .CSV?
Note: Rename works manually entering ‘Serial’ and ‘Name’ value (see image)

Rename iPad csv image


The trailing values of this command is incorrect? {{Serial}} and {{Name}} is not pulling values from our .CSV after uploading our .CSV and choosing “Run” command

I’m not sure what it is you’re trying to do here as its a 3rd post for thier flow but I can see that in both the CSV and images on the post - The variable names are serial and name.

In your CSV, you have Serial and Name which wouldn’t match the variable place holders in the collection.

If you’re making changes in the Collection, ensure that you save them before running the Runner, as it won’t know about the change until they are saved.

That happens to me too. If I do it individually I have no problem but when I relate it to the .csv it gives me the same error.
Can you tell me how you have solved it?

I leave my code:

“id”: “ed2f93b8-c1873-4949-979b-2d5a435353beb”,
“name”: “Number”,
“url”: “ serial=D………HW&deviceFields={%22name%E2%80%9D:%E2%80%9……%20….%E2%80%9D}”,
“time”: 307,
“responseCode”: {
“code”: 400,
“name”: “Bad Request”
“tests”: {},
“testPassFailCounts”: {},
“times”: [
“allTests”: [

Thank you