Iteration data not passing


Hello Danny, thanks for all of your help. Let’s get to the bottom of this


Thanks for bringing it over here - If I can’t help, someone else might be able too :slightly_smiling_face:

I’m kinda thinking that the URL isn’t getting updated when you make the changes.

Are you able to change something obvious in both the environment and collection, then make a single call to get that response back from the Postman API and check those values have changed?

Hello @danny-dainton

I added a call called Issuing Token test in postman submit sales collection and it updated in postman, but that update was not reflected n the newman command line runner. (view screenshot below)

So that’s suggesting that the collection isn’t updating from the Postman API right?

If that is the case, it would be the reason why you get the same response data back. The first time you created it with that hardcoded value, would be the one it’s using for your runs.


I updated the password in my environment and that caused my sales token test to fail. That means that the changes in the environment are updating but not the changes in the collection. (view screenshot below)

Hello @danny-dainton I had two collections with the same name and I pulled the wrong Uid.

Is that the mystery solved?

Have rerun everything again with the Collection that you’re updating?


mostly solved. I have an issue with the CSV being used to import the data, but that is completely different. It works perfectly whenever I use json

1 Like


You saved my life. Thank you!!!

1 Like