Invalid name parameter using collection runner to copy workspace

I am copying a workspace using the sample script “Copy a Workspace”.

While GET workspace returns 200, the POST workspace request is returning this error:

“TypeError: Cannot read properties of undefined (reading ‘id’)”

When I look at the response body in the console, I see this error:

{“error”:{“name”:“invalidParamError”,“message”:“body.visibilityStatus is invalid”}}

The request body is programmatically populated by the sample with my first name, the date, and the workspace I am trying to copy in this format:

“workspace”:{“name”:“[MY FIRST NAME] 2/16 - [WORKSPACE]”

I have tried manually changing the request body to a simple string containing just my name under the ‘Variables’ section and I have tried manually defining a “name” variable in the same section. I don’t think either of these get at the problem, but I am unsure what the workspace is actually expecting and why the request isn’t processing.

Please help. Thank you!