Help with the fetching field in Viusalizer

My question: I’m new Postman user and while working on Visualizer, I 'm unable to get one of the field’s value (ttps) while I’m able to get others.

Details (like screenshots): The raw results shows up as (in body)

"results": [


        "id": "4619594586387b16bb9d11eba3c2335b8e1426d6s",

        "workflow": {

            "state": "OPEN",

            "remediation": null,

            "last_update_time": "2021-05-23T08:04:49.555Z",

            "comment": null,

            "changed_by": "Test"


        "notes_present": false,

        "tags": null,

        "reason_code": "XXXXX",

        "process_name": "Test.exe",

        "threat_indicators": [


                "process_name": "test.exe",

                "sha256": "903ae6b93a789f8862cc774068f284ba0d6daa823499212f1048db98255fb395",

                "ttps": [




How I found the problem: in the Tests field , I entered code to fetch ttps but it shows up blank.
Here’s the few codes from the Visualizer Test Field.const template = `

{{#each response.results}}


; pm.visualizer.set(template, { // Pass the response body parsed as JSON as data`
response: pm.response.json()

What should be the ‘td’ field to get the value of ttps?

I’ve already tried: I have tried just putting ttps, threat_indicator.ttps with no success.

Let me know if more information is required?

Alert ID TTPs
{{id}} {{threat_indicators.ttps}}

@Sameer Welcome to the community :partying_face:

I see similar posts in the forum, please check these:

If you still have issue, please post the detailed script section or some snapshot :blush:

@bpricilla : thanks for a quick turnaround, I’m able to get the desired results :slight_smile: . Thank you!

1 Like