Got Version Mismatch error after downgrading to v7.34

I downgraded the Postman app from v7.35 to v7.34, because I was having some issues with that version. I deleted the AppData\Local\Postman\app-7.35.0 dir, and installed with v7.34. Then, I got the Version Mismatch error.
and got stuck at this screen:
Capture 2

I edited the AppData\Roaming\Postman\storage\settings.json file, replaced “lastKnownVersion”:“7.35.0” to “lastKnownVersion”:“7.34.0”, but still got the same thing.

It seemed that the app was checking some other files. Is there any other files I need to edit to get the app working?

I’m using Win 10. Thanks.

Hi @kcky1119! Welcome to the Postman Community!

I came across another thread with some similar issues. You may want to delete the files in C:\Users\AppData\Local\Postman as well.

You can check out the thread I’m referring to here, and the specific comment where a user had some success is available here.

Hope that helps!


Tried deleting all the files from AppData\Local\Postman, still doesn’t work.

Deleting AppData\Roaming\Postman would also delete my settings. I don’t want to lose all my APIs calls, request bodies, OAuth settings. I have almost 100 of them and building up from scratch is a pain.

I’ve read some suggestions, like copying AppData\Roaming\Postman folder to “Postman.old”, and worked ( ). However, this is not an option as old data will be gone.