Getting nowhere fast with Oauth2 - doens't recognise the application

I’ve been fiddling around with this for too long… I’m trying to connect to an API using Oauth.

I’ve got to the point where I hit to get access token… filled in the fields as best I can… I hit get token… I sign into my account… and it says:

Hmmm… we didn’t recognise that application.

Is this referring to not correctly linking postman in with my application? My application (Xero) only asks for an application name and an application URL (and a callback URL optional). I have tried linking the application I eventually want to connect it with, but that doesn’t work. And I can’t find what to link to put postman in there, I tried

Is that the problem when this error comes up? And what URL should I use to link postman?

EDIT: I have successfully linked to Imgur using Oauth2. But I can’t figure out what the difference is between Imgur and Xero.

Hi jocelyn1,

Are you trying to use Oauth1 or Oauth2?
Also, can you put a link to the documentation of the application that you are trying to authenticate?

EDIT: So I did it Hooray! BUT I’ve only got this token for 30 minutes. :frowning: I was hoping to grab the token and pop it in a header and wala I combined my apps… boo. I can’t do this? I seemed to be able to do it with Imgur. I have to go through this every time I want to access my app?

Oooooooh. Right. Thanks, didn’t really consider that, appears it is Oauth1a. The study I did implied that no-one is using that anymore so I didn’t think about it.