Getting error in evaluating the pre request script

while sending a request i’m getting:

There was an error in evaluating the Pre-request Script:TypeError: Cannot read properties of undefined (reading 'sigBytes')

the pre request script is empty
what can cause this error?

Details (like screenshots):

it just happens on every request i try to send

I’ve already tried: creating a new request, and it happens again

Hi @payload-meteorologis,

Welcome to the community :wave:

First verify if the request is saved. Next, as the error still points towards the pre-request scripts, I suspect this could be due to the collection level “Pre-request” scripts entered. Can you click on the collection and see if there is any script added there, if yes clear them next and let me know if that helps.

1 Like

Hi! Thank you for the fast response.
When i save the the request, the error still points towards the pre request script even though there is no pre request script right now.
there is also no script on the collection level.
it is very strange.
when i open a new request, first it doesn’t happen, but after i add the script, i can’t undo it.
if i remove the script, i still get errors fro the pre request script
EDIT: Oh sh**, i found a sub folder that has pre request script

1 Like