'form-data' works for POST request, but not 'raw'

I am making an api call that takes three parameters in the request: client_id, authorization_id, and query_params, a list of optional configurations. Essentially what the API call does is give you back vehicle information when you give them a VIN number. When I put these three parameters into form-data, it works and I get back all the correct vehicle data I was expecting to see. When I use the raw tab, with an identical JSON object, I get back ‘Authentication Failed’. This is driving me nuts as I believe solving this would also be the solution to the reason it won’t work in my AngularJS application where I get back the same error response. I checked the network tab for the response in my application, and double checked the headers in Postman, and they both have Content-Type: ‘application/json’, I am at a loss as to why one would work, and not the other.

1 Like

What JSON structure does your endpoint expect and what does your “raw” data look like in the body section ?

Hello, I have the same problem.

I share the screenshots with all the forms I have tried; But in form-data if it works for me.