ERROR: unsafe legacy renegotiation disabled

I’m getting an error when attempting to pull data from a vendors API.

here’s the full error:
Error: write EPROTO 78BB7B63CA7F0000:error:0A000152:SSL routines:final_renegotiate:unsafe legacy renegotiation disabled:…/deps/openssl/openssl/ssl/statem/extensions.c:907:

I have very little experience in Postman and don’t know how to address this issue, the vendor was very little help and simply said they can connect via postman on their end just fine. Pushing the issue to me as an issue on my side. I’m using Postman web. Per the error it seems to me that there’s a server setting on the vendors side that is the problem. My production code runs fine making calls and getting data back from the vendor API, ONLY postman is showing this error. My prod code uses the same URL that i’m using for postman. It should also be noted that postman works for our other vendors, just not this particular one.

I don’t know about the error specifically, but if the vendor is saying that its working fine their end, then get them to provide you with a working collection as a starting point.

Apart from that, as the error is mentioning SSL, you might want to try turning off the “SSL certificate verification” in the general settings.

Also try the desktop agent instead of the web agent as there are further SSL options that aren’t available in the desktop agent. (Maybe confirm with the supplier if their “working” Collection is via the web agent or the desktop agent\client.

If it is working elsewhere, then at first glance it does seem to indicate an issue in Postman and I would be looking at SSL settings.

Thanks mdjones, I downloaded the desktop agent. And everything starting working. So the issue looks to be in the webagent.

I’ll close this topic.