Error in test on api / auth

hello and thanks to all.
I apologize for the form in which I present the problem, but I am new and know little English and I have to rely on google translator.
I’m starting to manage a web application with frontend in Angular and Backend in Laravel. I have arrived at the authentication stage with jwt and, after creating the controllers I am trying to post an authentication on Postman. i put the following url
http: // localhost: 8000 / api / auth / login with post method
I am wrong
Error: getaddrinfo ENOTFOUND http;
how can i solve?
Please help me understand where I’m wrong.
Since I am a neophyte, please comment on the answers also in a simple way; I would like to be able to understand must be wrong and any suggestion is welcome.
I remain available for any further clarification
Thanks
Moreno

I would like to accompany the post with screenshots, but I don’t know how

Hello @misonsa, welcome to the community :wave:
I’m not entirely sure if I got your question correctly, but I’ll try pointing you to the right direction.

The error you provided us with Error: getaddrinfo ENOTFOUND indicates that Postman is not able to reach the endpoint you provided.

Can you please let us know if you are using Postman native app, or Postman Web App.

In case you are using Postman Web App you will need to install Postman Desktop Agent in order to be able to reach services that are hosted on your device, and since in your case you are trying to reach localhost, please make sure to download the desktop agent.

You can enable the desktop agent by selecting any request, and navigating to the right end at the bottom where it says Auto-select agent click on it and make sure Desktop agent is enabled, if you don’t have installed you will be automatically prompted to install it.

In case you are already using the desktop agent or the native desktop Postman app, you might want to double-check the following:

  • Your server is not running - Make sure your server is up, and endpoints are reachable.

  • You are using incorrect port - e.g your server runs on port 3000, but you are trying to reach it on port 8000

  • Make sure there are no spaces between the different parts of the url, since the way you posted it it appears that there is some white spaces between it
    http: // localhost: 8000 / api / auth / login should be → http://localhost:8000/api/auth/login

Hopefully this can lead you to resolving your problem.

Best Regards,
Atanas