Error: connect ECONNREFUSED 127.0.0.1:80

Hello,

I have this error. Could you help?

I’ve checked:
General:
ssl: off
request timeout in ms: 0

Proxy:
This proxy requires authentication: unchecked
Use the system proxy: unchecked
Add a custom proxy configuration: checked
Proxy Type HTTP HTTPS - checked
Proxy Server: 127.0.0.1 : 8080
Proxy Auth: off

Console:

Error: connect ECONNREFUSED 127.0.0.1:80
Proxy
authenticate: false
disabled: false
host: "127.0.0.1 "
id: “fc58a55e-fac7-40b1-95b6-53760ef1411f”
match: {…}
port: 8080
tunnel: false
Request Headers
User-Agent: PostmanRuntime/7.25.0
Accept: /
Postman-Token: 99e03e24-fe65-4348-83d0-d8a3bcc1a84f
Host: localhost:3000
Accept-Encoding: gzip, deflate, br
Connection: keep-alive

Regards

Hey @sync_bear,

Welcome to the Community :wave:!

It looks like you’re sending a request to localhost:3000, but your Proxy settings seem to be set to 127.0.0.1: 8080 Is your server running on Port 3000 or 8080? If it’s 3000, you could try making the relevant change in your Proxy settings to reflect that. I hope this helps!

2 Likes

Hello,

you saved my time, a many minutes;)

It should be: Proxy Server: 127.0.0.1 : 3000

Regards

if you are using Anypoint make sure you don’t have an empty flow, if you have one you need to delete it run your project again