Error 429 Too Many Requests in the flows

Hello, something very strange is happening with a specific flow of our system. After some time receiving requests, we are getting the following error: too many concurrent, potentially long running flow executions. (HTTP Status Code: 429).

I cloned this same flow, generated a new URL, and the flow started working normally again. After a while, the same error returned. I tried the URL of the old flow, and it worked in the same way.

We are not sending many requests at once; it’s happening one every 15 or 20 minutes.

I am not able to figure out what is happening with this specific flow.

Captura de tela 2024-05-31 141819

Hi @HigorCHS

Can you open and view one of your flows running in the cloud (view published flow option under the three dots next to the webhook url) when an execution occurs and make sure it completes?

We rate limit the number of concurrent flows at 10. If there is a logic error that causes your flow to run indefinitely this can cause the issue, as can triggering too many flows at once (sounds like this isn’t your issue).

Hi @flows-daniel

I checked the flow execution, and I’m receiving some error messages. The error message states the following: flow failed to run since the concurrent flow limit was reached.

I sent a request to the webhook and noticed that the flow executes all actions twice.

Counting the requests and removing the duplicates, there would be a total of 11 requests to APIs, but all in a cascade, depending on the success of the previous one to continue the flow execution until completion.

I am investigating to see if there is any flow stuck or in an infinite loop, but the strange thing is that after cloning the flow and changing the URL, the flows execute normally.


Hi @HigorCHS

Can you clone the flow and deploy it then view the running flow to make sure the flow completes after each execution? It looks like the current one won’t be running due to the rate limit issue (hence why logs only have starting execution instead of the whole execution log).

Hi @flows-daniel

I cloned the flow and deployed it; the flow runs normally without errors, but the status of waiting for the flow to run continues to occur.

All requests run normally, and we receive the responses from the body in our system, but after a while, the flow starts to give a 429 error.


can you send us your flow id and team id in a dm (or open a support ticket and tag me in it with these details)? Likely you’re getting throttled, we can adjust these limits once we review the account.

Hello, @lunar-module-geosci1

I sent you a DM with the IDs you requested.

Hi, @lunar-module-geosci1

Any updates on the case?

Hello, @flows-daniel, @lunar-module-geosci1.

With the instructions from @lunar-module-geosci1, I was able to identify the Evaluate block that was causing issues and getting the flow stuck. Now everything is working! Thank you very much for your time and help!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.