Day 14 of Postman 30 - OAuth: Auth added correctly test fail

“Auth added correctly” test failing in Day 14 of Postman 30:

I’m on Day 14 of Postman 30 and I cannot get past this 1 test case failing. I believe I have triple-checked all of the steps to set up the OAuth token. The callback URL matches. I am seeing all of my repos returned when I make the request in the OAuth folder.

image

image

The error I am getting is “TypeError: Cannot read properties of undefined (reading ‘type’)” so it thinks the property of “auth” is undefined.

I have tried console logging out the oauthFolder variable and sure enough, auth property is not there. I thought it may be because “Share Token” was not toggled on in the Authorization settings but I tried to enable that and the test still failed. Also… not sure if enabling that is a security concern.

I have tried on both the Postman desktop app and the Postman web app with the same result of only the last test case failing.

Hey @aviation-cosmologi14 :wave:

Welcome to the Postman Community! :postman:

Could you share the Public Link to your Workspace so we can have a better look, please?

Just ensure that you have added that to the OAuth Folder and not at the Collection level.

1 Like

Thanks! You’re right, the issue was that I added it to the Collection level. I thought I tried at the OAuth folder level to but I guess not :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.