Could not get any response_ POST Request

I am new to postman and I tried to send following post request:
{“username”: “”, “password”: “tarishah1993”} (//sent body)
“Content-Type”,“application/json”, (//header)
I am getting following error.
“Could not get any response
There was an error connecting to http://localhost:8080/rest/auth/1/session”.
in postman under error log I am getting following:
Error: connect ECONNREFUSED
Warning: This request did not get sent completely and might not have all the required system headers

Why this might have happened:

I have turn off “SSL certificate verification” in postman setting.
Checked with my service provider to confirm 8080 port is open for my machine
Tried to disable firewall
But still can not run this post request.
further more I opened chrome and paste this request direct their but got error message:
“this site can not be open”. Someone told me might be my server is not running but not sure how to check this. Any help will be really appreciated, as I mentioned at start I am new into field and trying to learn.
Thanks everyone in advance for your help and reply

Hi @Tarishah

Welcome to the community :wave:

This issue primarily appears to be due to the proxy settings as the endpoint you are trying to access isn’t publicly accessible. Check if you are receiving the same issue for other requests as an example: Try sending the request -

If you receive a successful response then, try changing the proxy settings and see if that helps. Here is the screen-record for your reference on the same.

Hope this helps! :slight_smile:

Thank you, that really helped.

1 Like

i am facing the below mentioned issue while executing ASP.Net ( POST method ) via POSTMAN Why this might have happened:

  • The server couldn’t send a response:

Ensure that the backend is working properly

  • Self-signed SSL certificates are being blocked:

Fix this by turning off ‘SSL certificate verification’ in Settings > General

  • Proxy configured incorrectly

Ensure that proxy is configured correctly in Settings > Proxy

  • Request timeout:

Change request timeout in Settings > General

After update Postman I can not reach any server. So After days of figuring what was the problem I switch to Insomnia. Spare your time.