Connecting to MS Project Online - help?

Can someone help me (explain it like I’m 5? step by step?) get connected to Project Online. Google’s been little help, every search results in Sharepoint connection help, but always fails.
Specifically I want to connect to[whatever this path is supposed to be]. my assumption is …/sites/pwa/ProjectData or …/sites/pwa/_api/ProjectData
I can browse to the paths and see the xml returned, but every attempt to get connected (using my own credentials or attempting to retrieve a token) with Postman returns “access denied.”
I have no access to the sharepoint/MSProject server, and our admin has been unable to help when it comes to permissions I may require, so if there are steps that need to be taken on the server prior to attempting to connect via Postman, could you please include those steps?

Thank you in advance

Hey @cpchambers and welcome to the Postman Community!

Could you give us a bit more detail as to which endpoints you’re trying to access? This seems like you may not be using the right credentials or may not be sending them correctly, having access to the API Documentation would help!

one of the endpoints I’m trying to get to is for that I just want to be able to successfully connect and complete a simple GET, but it always throws “access denied.”
I intend to hit other endpoints, assuming I can get connected, with the intention of retrieving project/task info, as well as POSTing updates - to timesheets, for example, along with resource assignments, etc.
but other than using a browser to get to, which returns the “big mess of projects in an xml dump,” i get “access denied” via Postman on anything I try. Even after following some googled suggestions and thinking I’ve retrieved a bearer token - “access denied” then, too.

thanks… for bearing with me.

Have you tried this one already?

Looks like you need to use a different endpoint when calling from Postman. If this still doesn’t work I’m not quite sure if we’ll be able to help as this seems to be a SharePoint specific issue, so I’d recommend opening a new topic on the forum linked above.

Thank you. I actually have seen & tried the suggestions on that link, but it was a no go.
with both endpoints using …/ProjectData/… or …/ProjectServer/…

I’m sure it’s a rookie mistake I’m making with authentication, I just can’t pin it down. Will keep digging, though.

Thanks, again.

small update / slight progress…
I had a bit of success using instructions here [well, they were here - they got flagged as spam and my post wouldn’t go, so I had to delete the link]

I connected, and am able to use postman to GET and POST (though they seem to be doing the same thing? retrieving a list of stuff in JSON format?)
I can hit this endpoint …/sites/pwa/_api/web but I can’t find my Projects, and don’t know how to get to …/sites/pwa/…/ProjectData/Projects so I can see actual projects listed and be able to query them or post to them.
I really can’t get below …/web assuming, of course, Projects are somewhere below …/web