Change the name on my awarded badge

My badge is awarded to my email, which does not look good. I want it to be awarded to my name. Could you please help me with that?

Hey @docking-module-arch3 :wave:

Welcome to the Postman community :postman:

Which badge are you referring too?

Did you see the instructions in the award email, showing you how your name can be changed?

Thank you for your response. It is Galaxy API Tester badge. In the email it says:
If the name displayed on the certificate, isn’t what you would like to see on there - You can update these details on your Badgr profile page.

I have checked my badgr account, I can edit my name and email. But this is not the problem. What I want to be changed is this:
Instead of: Awarded to myemail@gmail.com
I want: Awarded to My full name

And I cannot see any option to change it.

Thank you for your help.

Within your badge, you should be able to edit that to include your name.

Under the More dropdown there is an Edit option, you can enter your name here. It will be displayed like mine is in the image but it will still include your email.

The is a 3rd party service and we don’t control how they choose to display the information on their site.

Thank you again but I don’t have that More dropdown. :pensive:

Are you able to use the action menu in the top right next to Share, view the Public Certificate.

There should be a manage type option that will lead here.

This is the action menu. There is no manage type option… View public page gives a link to the badge with the same information.

This is a different badge but it should work the same, from you image go to View public page.

On the public page, I hit Manage it here:

This hit the Edit option from the dropdown:

Then I could add my name in the field and save the changes:

Hello Danny.
I am facing the similar issue in Postman 30 days of code.

I have opened the public version of the badge, but it is not showing there. Can you help me out

Hi @rtopdar. Following the steps @danny-dainton described above should also help you fix the issue.

Thank you Danny for all your efforts. But I don’t have “Manage it here” option which you have in your screenshot. Anyway, I give up for now. :slight_smile:

Hi @docking-module-arch3. When you click the “print certificate” option. The actual certificate carries both your name and email.

The “awarded to” is only seen by you, but the certificate you share with people contains the correct information. It is awarded to your email by default because your email is a unique identifier.

Thank you for your response. Yes my name is on the certificate. But I want my name to be shown when I share it on my Linkedin but is not.

The certificate are created and maintained on a 3rd party service, we have very little control in what we can do here. There are certain areas that can be changed, like we mentioned but we don’t have the control to change everything - Anything else, would be something that Canvas/Badgr would need to do here.

1 Like

I understand it, not a big issue. Thank you again!