Certificates for MQTT have `https://` as `Host` option

Problem/Solution attempt
I am trying to subscribe to a Topic from the AWS IoT Core MQTT broker using the Postman App (Windows).

  • I’ve added the MQTT connection
  • I need to add the certificates for authenticating, but under Host there is only the default option https://, not the mqtts:// that is required
  • I tried adding the certificates and using the MQTT endpoint in the Host field (even though it says https://) but this timesout when connecting

I have used the same settings / certificates with another desktop application - https://mqtt-explorer.com/ and it works correctly.

How can I add the certificates correctly for MQTT in Postman?

Platform Details
Postman for Windows
UI version=10.23.5-ui-240220-1406
OS platform=win32 10.0.19045

Certificate settings I can’t change

Hi @flight-engineer-6573! Thanks for your post! You mentioned using the AWS IoT core, which I believe uses ALPN. Right now we don’t support ALPN but something we will look to add in the near future. Right now the way you have added certificates is correct, but thanks for letting us know about how this process is unclear and I’ll take a look at how we can improve this area.

@flight-engineer-6573 wanted to follow up. I was looking into your issue and saw you’re connecting over port 8883, which is the MQTT port that shouldn’t require ALPN.

Could you let me know if, when you enter the URL in the request itself, you are using [YOUR_URL]:8883, mqtt://[YOUR_URL]:8883, or mqtts://[YOUR_URL]:8883? Could you also screenshot your settings tab of the request?

Hi @docking-module-admin, thanks for looking into it.

Request url format:

However, I’ve also tried your other suggestions as well:

With no protocol set or with mqtt:// Postman shows “connecting” for a long period then stops (with no message)

With mqtts:// Postman shows “connecting” very briefly than stops (with no message)

Settings tab:
(I have tried with and without “Enabled server certificate verification” enabled)

Hello, I have the same issue as @flight-engineer-6573.

I have tried:


Both times with and without “Enabled server certificate verification” enabled.

Everytime Postman tries for a long time to connect, then I receive the error message “An error occurred: connect ETIMEDOUT”

I would be interested in the solution to this issue as well.

@marlene.hildebrandeh thanks for letting us know! Could you confirm your platform details?

@marlene.hildebrandeh @flight-engineer-6573 I’m having a bit of trouble reproducing this. I was able to connect to an AWS IoT device using certificates on port 8883.

Here is my setup:
Screenshot 2024-03-13 at 11.32.49 AM

I’m using Postman version 10.24 and the certificate and private key provided by AWS. Let me know if you notice anything different on your end so we can troubleshoot the issue better.

Hi @docking-module-admin, thank you so much for your help and swft replies. As it turns out, my issues are unrelated to Postman, but in fact linked to the setup of my company’s network :frowning:

Thanks @docking-module-admin, I’ve just updated Postman, started from scratch again and setup exactly as per your screenshots and it works now!

Thanks for the help :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.