User Feedback - WebSocket support

Well, that feature should be released in production mode ASAP, I need to save socket connections in my team’s collection!

3 Likes

Nice and welcomed feature!
But i got a little problem with it.

lets say I have a socket server with a namespace in it:
URL: http://localhost:3001/mynameSpace

io.of("/mynameSpace").on('connect', function (socket) {

    console.log("Connected!") //Reached!

    socket.on('disconnect', function () {
        console.log("Disconnected!")
    })

    socket.on('Test it!', function () {
      console.log("test it") //Not Reached ):
    });
})

How can i emit messages for it to reach the socket.on('Test it!,… scope?

Tried using few args, one arg, Text format, JSON format.

i’m using Socket.IO version 2.x.

BTW, if i’m not using namespace i can use Raw mode, send a text message with this format:
42[“test it”,{“Foo”:“Bar”}]
To this URL:
ws://localhost:3001/socket.io/?EIO=3&transport=websocket
and it’ll work, BUT i cannot use namespace with this method.

Please help!

Thanks!

I am facing the same issue when there is namespace. Based on comment by @udit.vasu, namespace can be added in URI. I still can’t get what custom path in handshake path means.

Ok, I solved my problem.
I missed the part where you can specify the event name in the text box to the left of the Send button.

If you’re passing a JSON, make sure you’ve chosen a JSON format message.

Hope it’ll help you too.

I would love to see basic authentication for wss. Thank you!

+1 having a saved list + the ability to export them etc would make this feature mega

Could you please help me achieve the following Altair functionality in Postman:

Screenshot 2021-09-17 at 15.48.18
Screenshot 2021-09-17 at 15.51.25

What I currently see is that I can use just ws for Raw Websocket Requests and wss for Socket.IO but just using GET and not POST and also have no idea how to properly use the request body :slight_smile:

Please add the save websocket request feature(enable save button) as soon as possible. Without it, I don’t see much use of this feature.

1 Like

Postman does not receive responses when running ws://localhost:3001

Set-up:
2021-09-18_10-57-57
Running WebSocket API in localhost:3001.

Requests made from Postman to the above are always successful and execution continues up to the “send” command to return the results. Unfortunately, the response is never received in the postman console:

However, when the same codebases is deployed to AWS, it works perfectly, as the console reveals the successful response below:

I have also attempted to connect from a Firefox, Brave, Chrome console request. The results there are the same. Successful send, no response.

Logical deduction tells me my iMac is blocking traffic. Would this be the case? Or, am I missing a configuration step in my Postman set-up?

Jay

Did the “Websocket support” supports Authentication particulary the “Basic Auth”?

I was able to connect to websock using RAW but the app crash as soon as I try Socket.IO it crashes. Any idea what i am doing wrong?

Sorry new here, but was wondering if there is any way to define the socket config.
Ex:
const socket = io(namespace, {
path: ‘/io’,
withCredentials: true,
});
Mainly with the withCredentials, that is because it captures the cookies set by the server “Authorization Bearer token” And it gets push forward when the socket is connected and appended to the header.
In my own application, I have other users log in through regular HTTPS, once they get authenticated, the UI will start using SocketUI for the rest of the communication passing the credentials on every request.