Unable to merge feature-branch to the Version control branch

In Day 2 of the training, While I was trying to merge the ‘feature-branch’ to the ‘Day 02: Version control branch’, ‘Merge All Changes’ button is disabled and is showing the error “You need to have editor permissions on the destination to merge the changes”. I tried to rise Pull Request as well, but even though my collection is in public workspace I got the error “Reviewers can’t access the source collection. The source collection is not in a public workspace. Move it to a public workspace so that reviewers can access it to review your pull request.”

Hey @ashitha0510 :wave:

Welcome to the Postman Community! :postman:

I’m not sure what you’re done to get to this point but after the following the documentation, my Collections for Day 02 of the challenge look like this:

Here’s the documentation that help in the Version control folder:

It might be a good idea to delete the other Collection that’s been created and start again from Step 1.

Hey @danny-dainton

Thanks for the reply. Deleting the collection and starting again worked for me:+1:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.