Postman runner "This request does not have any tests"

I do not understand this error. I do not want to run a test. I just want to perform a simple delete operation in Okta. I have never used Postman before. I can run a list of users using a pre-written Okta collection. Ithen tried the Okta delete uses with a small2-line .csv file and I keep getting this error. Code: [DELETE {{url}}/api/v1/users/{{username}}]. Postman runner Result: “This request does not have any tests”.

Hey @steve.robey

Welcome to the community! :trophy:

So the message isn’t an error, it’s just informing you that, those particular requests, don’t have any Tests associated with them in the Tests tab in the Request Builder. It doesn’t impact the Collection run in any way.

The issue that I can see here is that the request is returning a 404 Not Found, as you are using variables {{url}}/api/v1/users/{{username}} it might be that those are not resolving during runtime.

HI Danny, Thank you for a quick response. I was just looking at the 404 Not found, and I think you are correct and my query is not finding the users. So I need to dive into why this is occurring as I know the two users in the .csv file exist. Okta provides the simplistic code including the name for the variable for the users, but they show it with two different names, once “username” and once" userid". I have tried both and the preview of the .csv field looks ok. I have a call with Okta support this morning and although I know that Okta support people want nothing to do with customer code that deletes deactivated users, I hope I can figure out what is wrong. Here is the link to their sparse documentation: https://support.okta.com/help/s/article/How-to-bulk-delete-users-via-Postman,

Are you using the same CSV file from that article or one of your own?

Have you set the {{url}} variable anywhere else?

It looks like that CSV is only showing the {{username}} key/value so if the domain part isn’t resolving, it wouldn’t work.

If you click on the request name, in the image you posted, you will get more details about the request - This will show the resolved URL.

You should be seeing something like:

https://example.okta.com/api/v1/users/test1@rares.local

but if that’s like this:

https:///%7B%7Burl%7D%7D/api/v1/users/test1@rares.local

That’s the issue. :smiley:

The ‘url’ looks OK:PostmanError1
But the ‘username’ variable is ‘Unresolved’. How do I fix this?PostmanError2

Is that the same environment file that you using during the Collection Run?

If you’re using the Collection Runner with a CSV datafile like this:

username
Danny
Steve
Bob

It will resolve that variable at runtime.

If you’re in the Request Builder, like I can see you are, you could add a new username variable to your environment file with the value of a user you want to Delete and try it out to see if it’s working as expected before moving to the runner again.

Hi Danny, you are definitely pointing me in the correct direction. Looking up and using the Using the Okta ‘userid’ (looks like ‘00u3565wcwJQN0pm62p7’) in the Request builder works. But using the same code to run in the Collections run still cannot find the user. Even my Okta support person was unable to help me yet and will have to get back to me however. In the meantime I am going to punt with postman as I was able to get their PowerShell code to work correctly and delete the 2,800 deactivated users. I’ll post back here if I ever get it to work correctly. The Okta document page that I referenced above is clearly not correct.