Link to badge submission form not working

I’ve just completed the API Adoption training collection but the form link in the documentation section ( to submit the finished collection doesn’t work.
Hope someone can help with this

Looks ok to me, do you have anything running that would block it?

Thanks for responding.
No, I have checked it on 2 devices and neither work - clicking the link does nothing, opening the link in new tab takes me back to the postman workspace.
I tried the link from the collection I forked from but it’s the same behaviour for me there too

Try this, it’s the Google link, not the link;

Thanks very much, that worked.
I’d like to do the other training as well but I’d rather not have to create a Topic here every time. Is there somewhere I can get the links for the others?

I suspect your issue is that something on your computer is blocking links.

Here are 3 of the training submission links;

If there are others, just drop me the link in a message.

Much appreciated. Thank you