Interceptor integration for Postman Native Apps

Hi, I am having a similar problem where interceptor is showing as disconnected. I have the correct versions of chrome, the postman app and postman interceptor installed. I also tried to install the bridge. The is one bat file that just adds an entry to the registry to point to the json file and an exe that when I execute it is seems to do nothing.

Also, when enabling cookies, I am not able to add any domains. maybe it needs to be connected first?

please let me know what else I can look at.

thanks

john

Hi,

  1. I’ve had postman working to capture API calls on mojave OS from the native app. The interceptor was green and showing as connected (as expected)

  2. After I have updated my Macbook Pro to Catalina a few weeks ago, the Interceptor is shown as disconnected and cannot see the API calls anymore.

  3. I’ve tried uninstalling, reinstalling the whole process, as mentioned on some of these posts and also from Interceptor integration for Postman Native Apps

  4. Nothing seems to be working anymore and I think it has to do with updating to Catalina, because everything worked smoothly before that.

  5. Can someone point me to the right directions as to what I have to do?

@valiL There are known issues with Catalina. The notarization requirement that was introduced in Catalina has broken this flow. We’re investigating possible solutions - will post an update here as soon as I can.

Thank you very much. Will wait for the fix.
Have a great day.

@abhijit I have the same problem. I have performed the following operations

  1. Install postman interceptor chrome extension
  2. Install postman bridge on Ubuntu 18.04 (I don’t know if it’s in the correct location though). I have placed the whole interceptor bridge dir inside /home/jc/.config/google-chrome/NativeMessagingHosts and run the install_host.sh file which creates a new com.postman.postmanapp.json
  3. Install postman native app for ubuntu.

image

Thanks in advance.

1 Like

Hi @ironjohn @valiL @baronmog @dsudenfield @jomenxiao @nick @Malaachi @brandon.kiefer @Idstn ,

We are glad to announce that we are doing some interventions around interceptor. I would love to understand and study your use-cases around the same. Would you be interested to get on a quick call? Please feel free to block a time slot as per your convenience using the link. Hoping you would come onboard :slight_smile:

Link - https://calendly.com/tithi-sharma/interceptor-user-flows

Thanks & Regards

1 Like

@valiL We’ve released an upgraded installation flow in v7.14 of the app. Can you give that a try and see if it works? Relevant documentation is at https://learning.getpostman.com/docs/postman/sending-api-requests/interceptor-extension/#troubleshooting-connectivity.

Hi Abhijit,

I’ve redone all the steps and now Interceptor is working as before. I can capture the calls now.
Thank you very much for the fix.
Have a great new year from Romania.

Has anyone figured out how to get interceptor working? I’ve tried following the steps, but step 3 of the installation is not helpful. It simply says

Select Install Interceptor Bridge to download the Bridge, an independent executable that ?> facilitates communication with the Interceptor.

If you’re on Windows or Linux, Postman will take care of everything for you. If you’re on MacOS, > you’ll be prompted to install NodeJS if it’s not already installed on your computer.

There is no indication of where that download is though. It’s not in the interceptor chrome extension nor on its chrome webstore page. It’s not in the postman native app. It’s not in the directions themselves. I found a direct link to the download but trying to install it using the included shell script doesn’t seem to help as Interceptor and the native app are both refusing to connect to each other. It seems like this is a problem multiple people have had based on the extension’s reviews in the chrome webstore. Any help would be appreciated.

1 Like

Sorry to hear that @mgraham24. Can you confirm what versions of Postman, the Interceptor extension you have and the OS you’re on?

There’s a known issue if you’re on Linux and have installed Postman via Snap, but we’ve been able to resolve most other issues.

I’m getting this error,

COULDN'T INSTALL
Postman doesn't have the required permissions to install Node.js and other dependencies. Read our troubleshooting doc for more information.
ERROR CODE: CHROME_NOT_INSTALLED

I know I have Chrome installed (replying to this thread from Chrome), Extension installed, NodeJS installled.

OS: Linux Ubuntu

@hkchakladar have you installed postman app via snap?

Yes, installed via snap. I just did a re-install via snap. Nothing changed.

@hkchakladar can you install postman from our website to use interceptor for now. We are working on the issue that you are facing.

Correct me if Im wrong but on the official page
https://learning.postman.com/docs/postman/sending-api-requests/interceptor/#installing-interceptor

In the docs, there is not a word about installing additional Bridge files from a zip package (point 3 in the first post of this topic Interceptor Bridge (available here) )

I had to google for this topic to start using the bridge on Windows because the docs were not sufficient.

Correct me or docs please :smiley:

Thank you