Interceptor integration for Postman Native Apps

On Requirements, are you sure you don’t mean Version 0.2.26 and above of the interceptor?

1 Like

Unable to add domains to the list. I get:
pm.interceptorBridge.cookieSync.addDomain(‘foobar.com’)
“adding foobar.com to the domain list…”
pm.interceptorBridge.cookieSync.getDomainList()
“fetching domain list …”
InterceptorBridge : No domains found

@baronmog Can you restart the Postman app and send a screenshot of the View -> Developer -> Current View?

Essentially, after the app restarts, you should see the INTERCEPTOR CONNECTIVITY: cookie sync enabled for the domains - Array(1) message.

@baronmog Can you re-attempt the quick-start steps? After installing the bridge, you should have the com.postman.postmanapp.json file in: /Users/nromer/Library/Google/Chrome/NativeMessagingHosts or $HOME/Library/Application Support/Google/Chrome/NativeMessagingHosts

If not, we’ll be happy to get on a call with you to sort this out.

Hmm. I’ve followed the instructions to install the Postman Canary app ( v 7.1.1), but I don’t see the any interceptor toggle inside the canary app to be able to enable the desktop application to see requests from the chrome extension.

Therefore, the problem I’m having is that requests are captured successfully in the browser extension, but nothing shows up in the canary app.

According to the existing interceptor documentation, I should expect to see an interceptor toggle in the header of the postman app, but inside of the canary version of the app, all I see is this:

@ldstn The docs are for the Chrome version only - we’re working on updating those. For now, you’ll need to use the command-line API (described above) to configure domains to sync cookies between Chrome and the Postman app.

Syncing history requests isn’t supported yet.

1 Like

Doesn’t work on MacOS for me. When switching “Capture cookies” on, it still displays INTERCEPTOR DISCONNECTED.

5 Likes

@brandon.kiefer Can you confirm you’ve completed the following:
Downloaded and installed the interceptor bridge as described above
Restarted Chrome

Toggling the capture cookies setting won’t affect the connection status. The status is only determined by whether Chrome is open with the Interceptor extension installed, and whether the bridge has been installed.

I should manually insert the domain name in the cookies manager as I did in the capture cookies interface or it should fetch it automatically.

At the moment I’m not able to get any cookies both ways.

@Malaachi
The cookies and domains will be populated automatically. Can you confirm the following:

  1. Chrome is open, and has the Interceptor extension installed (v0.2.26)
  2. You’ve completed the installation steps for the bridge
  3. The Interceptor Status isn’t updating to ‘Interceptor Connected’ even after restarting Chrome

If all three are true, could you contact us at help@getpostman.com? We’ll need to check system logs for why the connectivity isn’t being established.

does not work on MacOS for me either… I have restarted chrome and restarted my machine, and uninstalled and installed the interceptor.

2 Likes

MacOS update: it appears as tho you have to add the url you are trying to capture cookies for to the allowed_origins in the com.postman.postmanapp.json file

“allowed_origins”: [
“chrome-extension://aicmkgpgakddgnaphhhpliifpcfhicfo/”,
https://www.example.com/
]

then maybe restart your browser and restart postman. I also think you have to have chrome running before you start postman.

@nick That’s weird. The Chrome docs (https://developer.chrome.com/apps/nativeMessaging) state:

allowed_origins: List of extensions that should have access to the native messaging host. Wildcards such as chrome-extension://*/* are not allowed.

Did adding the example.com domain work for you? My guess is it could have been more to do with the restarts. Can you remove the example.com line, restart your browser, and check if the cookie syncing works?

Not work on MacOS for me

The Postman Interceptor have captured some reqeust.


and App show ‘INTERCEPTOR CONNECTED’.
image

But Cookies is not found.

@jomenxiao As mentioned in the blog post, you’ll need to enter the domain in the Postman app UI, in the “Enter a domain to capture cookies” input, and hit ‘Add domain’. Once this is done, the Interceptor will sync cookies for those domains.

The UI in the Interceptor extension in the browser is only for the Chrome app, and not relevant for this integration.

I have added the domain to “enter domain to capture cookies” section in multiple fashions as show below with replacing example.com with my real domain with to luck is there something I’m missing still? The intercepter is on in chrome and I recently restarted both the app and chrome.

Domains structure entered:
https://example.com
https://example.com/
https://example.com/*
https://example.com/path/to/my/endpoint

@dsudenfield you just need the ‘example.com’ structure, without the https:// part. Is the Interceptor Connected status showing up?

1 Like

Hi, I am having a similar problem where interceptor is showing as disconnected. I have the correct versions of chrome, the postman app and postman interceptor installed. I also tried to install the bridge. The is one bat file that just adds an entry to the registry to point to the json file and an exe that when I execute it is seems to do nothing.

Also, when enabling cookies, I am not able to add any domains. maybe it needs to be connected first?

please let me know what else I can look at.

thanks

john

Hi,

  1. I’ve had postman working to capture API calls on mojave OS from the native app. The interceptor was green and showing as connected (as expected)

  2. After I have updated my Macbook Pro to Catalina a few weeks ago, the Interceptor is shown as disconnected and cannot see the API calls anymore.

  3. I’ve tried uninstalling, reinstalling the whole process, as mentioned on some of these posts and also from Interceptor integration for Postman Native Apps

  4. Nothing seems to be working anymore and I think it has to do with updating to Catalina, because everything worked smoothly before that.

  5. Can someone point me to the right directions as to what I have to do?