Can I get more details about Idea #3 (Newman Dashboard) and need some help

Hello Sir,

I am Saurabh Srivastav. I am a pre-final year undergraduate currently pursuing a bachelor’s degree in Computer Science Engineering from Parul University, Vadodara, Gujarat. I am extremely interested to work as a student in GSoC with Postman.

I have learnt a lot during my internship period with some companies. I was not much active on open source because I was working hard on my internships, which really affected my skills to get better. I really want to work with postman during gsoc and after too as there’s nothing better than gaining knowledge and implementing it to get desired result.
I want to contribute to Postman by giving my best to GSoC Idea 3: Newman Dashboard
and Idea 10: AsyncAPI Applications Relations Finder, during my internship period I worked on Dashboard related project too and many other. All I need some support from mentor and I will push my efforts to do any task. I am eagerly waiting to give my best in the project. I want to know more about these projects and I can’t wait to work with postman.

Thanks and Regards,
Saurabh Srivastav

Please create 2 separate topics in the future for each of the idea discussions, but in the meantime do read up about Newman here

@pranav-singhal @lukasz.gornicki could you help him out please


@saurabh1901 please follow the steps mentioned above and do read the GSoC 2021 Guidelines - #3 here and request not to write to every mentor directly. We will respond at the earliest but request if could follow the guidelines and the previous message inputs


Sir, I am facing these errors after cloning the repo, during npm test.

As mentioned please update the title of this topic or let us know which idea discussion will continue here and direct us to the other one was clean communication.

Ideally the unit test which is failing must have been displayed above the table.
And if it is not so, go to npm/test-unit.js and log the runError on the console.

Sir, here it fails
integration test failed:
name: ‘AssertionFailure’,
message: ‘should authenticate correctly’,
checksum: ‘80949a6b30d038c5a4e9ea27d0088776’,
id: ‘3fecf1bd-9065-49a9-af53-a338e529bb41’,
timestamp: 1617255583865,
source: {
name: ‘test/integration/hawk-auth-test’,
collectionJSON: ‘test/integration/hawk-auth-test.postman_collection.json’
} { colors: true }
ERROR: Coverage for functions (30.57%) does not meet global threshold (35%)

Newman works fine or does it have an error too?
If it does, then you can go on while I try to dig out the cause for the same.

It seems, Newman also has some error because I am facing same kind of error while installing Newman globally.
If it takes time, it may affect my proposal too, I am still left with proposal making. I want to work on this Newman dashboard idea. Time is too short.

Yeah don’t worry.
I’ll do it quickly…

Just kinda worried, as I don’t wanna lose this chance of working with postman in this GSoC, anyhow.
Thank you so much. I am waiting to get it fixed.

1 Like

Actually I tried that with a fresh clone of newman and all integrations were fine.
Kindly clone it again and try once…

Sure, I’ll try it again with a fresh start.

  1. Clone this repository / your fork of this repository using git
  2. If not on develop , switch to the develop branch with git checkout develop
  3. Run npm install in the project directory
  4. Make sure everything is working by running npm test .

Just these four steps , right?

That much would be enough.

Still it’s same when I run npm test… I don’t know why.

Man, I can’t see whats happening here…
Maybe there’s something with the system configuration…
Is there any error with newman working…
Try running a collection and tell me what happens.

Hello Mentors,
Thankyou so much for helping me to solve this issue.

Hello Mentors,

Need help regarding Newman Dashboard Idea
Please respond asap.

@pranav-singhal @raghav.garg do assist