30 day challenge error : Test Failed

Hello,

When I am attempting to complete Day 12 for the 30 Day Challenge, when I submit my solution,one of test is getting failed ,Please find the attached screenshot

I have also checked in the particular request and applied test for finding the correct path in “get single workspace”. Getting same error over there as well “response.json().collection.auth is undefined” and when I have done some changes in path to finding out the apikey in response json and got the correct path but when I replace the response.json().collection.auth with the correct path in the submit the solution test then all the test has been passed but when I checked in Body >> visualize still it is showing " please try again "

Please can someone suggest me what I will do ?

Thanks for you help in advance

@RajatSharan2505 Welcome to the community :partying_face:

Can you please check the Authorization at collection level?

Yeah, I have already applied authorization at the collection level.

Sorry, Yes it’s the same with me as well :stuck_out_tongue: I proceeded after seeing the all test cases passed. Folks who completed already @neilstudd @zach Can you please confirm this? :blush:

Are we missing something here? :unamused:

Hi @bpricilla I can see the same Visualizer error - it says “failed” even when all tests have passed. (I just continued when the tests all showed passed)

I’ve tried to debug by adding a console.log next to each of the places that the pass variable is incremented (it expects to find this variable set to 5). However it is running them out of order, so when it checks pass == totalToPass it’s only been incremented to 2 by that point… not sure what the fix is for this.

image

Perfect, thanks for the prompt response @neilstudd :blush:

@joyce or @sean.keegan “Day12: Postman API” collection still shows as failed under “Visualize tab” :roll_eyes:

Shall we ignore this and proceed?

If all your tests are passing, you can proceed. Looks like some timing issues with the asynchronous calls.

4 Likes